
CS Programming Code Assignment 7: Ray2
Out: Saturday 21th November 2015

Due: Thursday 3rd December 2015

1 Introduction

Ray 1 introduced you to the basic principles behind this relatively simple, and at the same time
very powerful, algorithm for rendering images. In this assignment, we will enhance the previous
algorithm to trace multiple light bounces, which will allow us to render essential physical effects
that were impossible to produce before (e.g., reflection and refraction of light).

You will quickly realize that tracing multiple ray bounces fits quite nicely in the provided framework
and does not require much of an effort to implement, but it also reveals the major problem behind this
approach: its performance. Therefore, one of your goals in this assignment will be to implement
a hierarchical data structure that will accelerate the bottleneck step in ray tracing, the ray-object
intersection.

2 Requirement Overview

In Ray 1, you implemented the basic ray tracing; we will provide a package that contains what you
implemented from that assignment, plus some updates to the framework. You will extend this ray
tracer as specified below. This new ray tracer should support all the features of the one in Ray 1 and
the following features below:

• Anti-aliasing. Implement anti-aliasing using regular supersampling (Shirley 8.3, 9.4, 13.4).

• An acceleration structure. Your program should be capable of rendering large models (up
to several hundred thousand triangles) with basic settings in a few minutes. Achieving this
requires a spatial data structure that makes the time to trace a ray sublinear in the number
of objects. In this assignment, we provide a framework for axis-aligned bounding volume
hierarchy (BVH) which is a simple and effective way of speeding up ray traversal. (Shirley
12.3). Before you have implemented BVH, you can add <AccelStruct type=
"NaiveAccelStruct"/> in the scene file in order to test other parts of your implemen-
tation.

• Advanced shader: Cook-Torrance. You should implement a Cook-Torrance shader which you
are familiar with from the Shaders assignment. The only difference is that now you should
compute the fresnel term from the refractive index.

• Advanced shader: glass. A “Glass” material that simulates an interface between air and
adielectric material. The glass shader obtains its color from light intensity along two new
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rays, the reflected and refracted rays, and adds their corresponding contributions (Shirley
13.1).

• Environment mapping. Our framework can load a pfm (a HDR image format) file as environ-
ment mapping. You are asked to implement a method that looks up the color of the cubemap
in a given direction.

• We have provided a list of extensions that can be implemented for extra credit.

3 Implementation

A new commit has been pushed to the class Github page in the master branch. We recommend
switching to your master branch, pulling this commit, and creating a new branch (e.g., A7 solu-
tion) and committing your work there. This new commit contains all the framework changes and
additions necessary for this project.

We have marked all the functions or parts of the functions you need to complete with TODO#A7 in
the source code. To see all these TODOs in Eclipse, select Search menu, then File Search and type
TODO#A7.

3.1 Antialiasing

To support anti-aliasing, modify the renderBlockmethod of RayTracer to make the ray tracer
shoot multiple rays per image pixel. renderBlockmethod contains the samples variable which
is the number of samples to take per dimension of the image plane. (That is, the tracer should shoot
samples2 rays per pixel.) Note that we have abused the variable samples: in the xml file we use
samples to refer to N2, while here it refers to N .

3.2 Acceleration Structure

You will implement an acceleration structure called axis-aligned bounding volume hierarchy(BVH).
It is a tree whose leaves are surfaces in the scene. Each of its internal nodes contains an axis-aligned
bounding box(AABB) that contains all the surfaces in the subtree rooted at that node. An axis-
aligned bounding box is defined by two 3D points (xmin, ymin, zmin) and (xmax, ymax, zmax). The
box itself is the Cartesian product of three intervals in each dimension,

[xmin, xmax]× [ymin, ymax]× [zmin, zmax].

Before constructing the acceleration structure, you need to complete the computeBoundingBox
method of all the subclasses of Surface except Mesh. This method should modify three fields:
minBound, maxBound, and averagePosition. After calling this method, the AABB de-
fined by minBound and maxBound in world space should contain the represented surface en-
tirely in world space, and averagePosition should be a 3D position in world space inside the
AABB that can be regarded as the center of the surface in world space. We stress that minBound,
maxBound, and averagePosition are defined in world space; you need to take into account
the transform stored in tMat when implementing the method because all other fields are defined in
object space.
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After implementing all the computeBoundingBox methods, you are ready to complete the Bvh
class. Each node in the BVH is represented by an instance of the BvhNode class. The root node is
stored in the root field of the Bvh class. The surfaces the BVH manages are not stored in the nodes,
but they are stored all in one place in the surfaces array in the Bvh class. Each BvhNode contains
the surfaceIndexStart and surfaceIndexEnd subjected to the following invariant:

Surfaces stored in surfaceswith indices from surfaceIndexStart to surfaceIndexEnd-1
are contained in the subtree rooted at the node.

BvhNode also contains the minBound and maxBound fields that define the AABB correpond-
ing to the node. Moreover, it has child array which contains the references to its left child and
right child. You need to implement the createTree(int start, int end) method of
the Bvh class. This method should create and return a BvhNode that contains surfaces from
surfaces[start] to surfaces[end-1] in its subtree. To do so, you need to divide the
surfaces into two groups by sorting their averagePosition and modifying the surfaces array so
that the first group is in the left half and the second group is in the right half of the array. Then, you
call createTree recursively on the left and the right half to get two BvhNodes that will become
the two children of the BvhNode that you construct for the original call to createTree. More
details can be found in the comments in the code base.

Then, you will implement the intersects method of the BvhNode class. This method only
checks whether the given ray intersects the AABB of the BvhNode or not. There is no need to
compute the intersection point or other associated information.

Lastly, you need to implement the intersectHelper method of the Bvh class. This method
checks whether the given ray intersects any surface contained in the subtree rooted at the given
BvhNode. First, you should check whether the ray hits the node or not by calling the intersects
method of the BvhNode class. If not, the method can return immediately. (This check is the key
why ray intersection becomes much faster with a BVH.) Otherwise, if the BvhNode is a leaf, you
intersect the ray with the surfaces with indices from surfaceIndexStart to surfaceIndexEnd-1
one by one. On the other hand, if the BvhNode is an internal node, you call intersectHelper
recursively on its two children.

3.3 Cook-Torrance Shader

For detailed description, see the Shaders assignment pdf. There we used the Schlick approxima-
tion to compute the Fresnel term. Now after you have implemented the fresnel function in
Shader.java, you should use that to compute the Fresnel term instead.

3.4 Glass Shader

The Glass shader simulates an interface between air and a dielectric material. For its shade
method, it should compute the directions of the reflected and refracted rays using Snell’s law.
shadeRay should then be called recursively on each of these rays. The factor for the reflected
ray should be R, and the factor for the refracted ray should be 1 − R. You need to check for total
internal reflection in which case you only generate the reflected ray and set its factor to 1. One
caveat is that the method must work for rays coming from both sides of the surface; you can tell
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Figure 1: Additional rays to be generated for the Glass shader. In (a) and (b), one reflected ray
with scaling factor R and one refracted ray with scaling factor 1 − R are generated. Note that
the outgoing direction can either be inside or outside the surface. The angles θ1 and θ2 should be
related by Snell’s law: n1sinθ1 = n2sinθ2. In (c) and (d), total internal reflection occurs. Only
one reflected ray should be generated with scaling factor 1. Note that total internal reflection can
happen on the outside of the material despite its name because the ratio between n1 and n2 can be
arbitrary. Your code has to work correctly in all these cases.
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which side is outside by the fact that the normal always points outside. Figure 1 summarizes the
behavior of the Glass shader.

3.5 Environment Mapping

Figure 2: Example of Cubemap

The framework supports environment mapping as a background for the scene. For a scene with
a cubemap, rays that don’t hit any objects should look up the corresponding pixel value in the
cubemap. The framework can load a pfm (an HDR image format) file as the environment map. An
example of such a file is shown in figure 2. It’s just an unfolding of the six faces of the axis-aligned
cube into a cross. The corresponding directions for each of the faces are shown in figure 2.

You are asked to implement the evaluate method of the Cubemap class, which looks up the
color of the cubemap in a given direction. In the Cubemap class, fields width and height store
the width and height of the entire pfm image. The blockSz field stores the size of the square,
which is width/3. The pixel values of the pfm image are stored in the float array imageData.
The R, G, B values of a pixel are stored sequentially. And the pixels in the image are ordered row
by row, from bottom-left to top-right. For example, if we want the color of environment light in
direction (0, 0, 1), we need to look up the pixel value at the red point in Figure 2. It’s coordinates in
the image plane is ( x = 1.5 * blockSz, y = 0.5 * blockSz). And the R, G and B
values would be imageData[3 * (x + width * y)], imageData[3 * (x + width

* y) + 1] and imageData[3 * (x + width * y) + 2].
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4 Extensions

Once you have all of the required features working, you can continue having fun and collecting
bonus points at the same time, by implementing some of the extensions proposed below. If you
implement any of these, please leave a description of what you did in your README file, and
create an xml file or two to clearly demonstrate these features.

• Soft shadows. Shadow rays need not go to a single point, but can be distributed over an area
of the light source. Implementing soft shadows requires shooting more rays and distributing
them evenly over the area light. You will need to extend the model of lights to have some area
(a square area is convenient) for this problem.

• Camera depth of field. A real camera exhibits depth of field effects, such that objects far away
from the focal distance are blurry. This can be simulated in a ray tracer using distributed rays.
Refer to section 13.4.3 in the book (Shirley et al., Third Edition) for more details.

• Spotlights. Extend your point light source to be a circular spotlight. A spotlight has a direc-
tion, a beam angle θb, and a falloff angle θf , in addition to the usual position and intensity.
For directions that make an angle less than θb with the spotlight’s direction, it produces the
same intensity as a regular point light. For directions that are more than an angle of θb + θf
from the spot direction, it produces no illumination. In the falloff zone it drops off smoothly
according to a C1 function of angle.

• Bilinearly filtered texture mapping. Implement bilinearly filtered texture mapping for triangle
meshes. Use bilinear interpolation when you sample the texture.

• Metal shader. Implement a shader called “metal” that takes a complex refractive index, with
separate values for R, G, B, and uses them to compute Fresnel reflectance for a conductor.

• Glaze shader. A “Glazed” material that acts like a thin layer of dielectric over another ma-
terial, and reflects somewhat like a mirrored surface. The glazed shader also calls another
shader which computes the contribution from the substrate below the glaze (Shirley 13.1).

• Propose your own. You can propose your own extension based on something you heard in
lecture, read in the book, or learned about somewhere else. Doing this requires a little extra
work to document the extension and come up with a good test case. If you want to do your
own extension, email your proposal to the course staff list.

5 Handing in

Submit a zip file containing your solution organized the same way as the code in the repository,
together with your solutions for the written assignment. We strongly recommend you write your
solutions for the written part neatly in a PDF file. Include a readme in your zip that contains:

• You and your partner’s names and NetIDs.

• Any problems with your solution.

• Anything else you want us to know.
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6 Appendix A: HDR output

The ray2 framework supports HDR output. In order to use HDR output, set the writeHDR variable
in RayTracer.java to be true. We use the openEXR library to produce HDR output. You may
need to configure your native library location. To do this in Eclipse, go to Project → Properties
→ Java Build Path → Select Libraries → Select the openexrjni-3.0.0.jar. Drop Down Menu →
Modify Native Library Location. Modify this setting so that it matches your OS. Also in Project
→ Properties→ Java Build Path→ Select Source→ Select the CS4620/src. Drop Down Menu→
Modify Native Library Location. Modify this setting so that it matches your OS.

The HDR output file will be named as *.exr. You can download a tool from the following address
to view the *.exr files as well as the *.pfm files. https://bitbucket.org/edgarv/hdritools/downloads

7 Appendix B: Notes on File Format

The code base still use the same framework that was released with Ray 1. In this section, we note
some additional features that you can specify in the input XML file.

Transformations. We already give you the solution of group transformations, but you should also
know the input file format. The transformation is specified as a sequence of rotations, scales, and
translations, which are combined in the order given to define the transformation that is applied to
all members of the group. Translations and scales have components for x, y, and z; a rotation is a
sequence of three rotations about the three coordinate axes, with the x rotation applied first and the
z rotation applied last.

The file format can be defined by example. For instance, if a transformation is given as T: 1 2 3; R:
40 50 60; S: 0.7 0.8 0.9, this can be specified in the ray tracer as follows:

<surface type="Group">

<translate>1.0 2.0 3.0</translate>

<rotate>40 50 60</rotate>

<scale>0.7 0.8 0.9</scale>

<rotate>40 50 60</rotate>

<surface type="Sphere">

<!-- ... -->

</surface>

<!-- more surfaces, all transformed as defined above -->

</surface>

Cook-Torrance shader. You can specify the diffuse color, specular color, toughness and refractive
index for Cook-Torrance shader in the scene file.

<surface type="CookTorrance">

<diffuseColor>0.3 0.3 0.3</diffuseColor>
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<specularColor>0.2 0.2 0.2</specularColor>

<roughness>0.8</roughness>

<refractiveIndex>1.5</refractiveIndex>

</shader>

Glass shader. In the input file the glass material should be specified just by its index of refraction,
through a parameter named refractiveIndex:

<shader type="Glass">

<refractiveIndex>1.5</refractiveIndex>

</shader>

Antialiasing. This part is in extension, but we will offer the information for those who want to
implement antialiasing. The number of samples is specified by the samples property of the Scene
class. For example, the following input specifies a 640 by 480 pixel image rendered with a 3x3 grid
of subpixel samples for each pixel.

<scene>

<camera>

<!-- ... -->

</camera>

<image>640 480</image>

<samples>9</samples>

</scene>

You are free to round the number of samples to a convenient number (for example, to the nearest
perfect square). Use any rounding technique that youd like, as long as specifying a perfect square
results in exactly that many samples. Note that the samples element here is approximately the
square of the samples variable in the renderImage method.

AccelStruct. The type of AccelStruct used can be specified by a single line as a child of scene.
This may be useful for testing your AccelStruct implementations, especially for scenes with large
meshes.

<scene>

<accelStruct type="Bvh" />

<!-- ... -->

</scene>

Cubemap. You can use specify the directory of the cubemap in the xml file, just as follows.

<scene>

<cubemap>

<filename>texture filename</filename>
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</cubemap>

<!-- ... -->

</scene>
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