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Objectives

After reading this chapter, you should be able to:

• Use the Maple graphical user interface

• Describe the components of a Maple worksheet

• Enter input to produce output

• Collect input and output in an execution group

• Perform basic computations and plotting in Maple

• Use palettes and context-sensitive menus
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PROFESSIONAL SUCCESS: LEARNING ABOUT MAPLE

No matter how exciting and engaging Maple, or any material, may be, nitty-gritty details might

drag you down. But, learning need not bore you! Pique your interest and motivation with these

tips:

❐ Familiarize yourself with the text:

Successful professionals never know everything – they just know where to look. Quickly

flip though all chapters and appendices. Look for handy features, like solutions to

problems and reference tables. You should also compare your course syllabus with the

text’s organization.

❐ Learn the notation:

Thoroughly understand all notation! Otherwise, lost shall you ever be!

❐ Set goals:

Carefully read your assignments and text, but never try to learn everything at once!

Attempt only a few portions at a time. Taking small steps will improve your retention and

prevent burn-out.

❐ Practice reading:

Learning requires both understanding and practice. Study the text by skimming the

assigned readings a few times so you may gain a general understanding of the new

material. Then, more carefully read smaller portions and practice the demonstrated

examples. To stay focused, periodically remind yourself of chapter objectives.

❐ Practice implementing:

Follow the suggested examples in the book. Always try to understand the reasoning

behind each exercise and predict the possible output before attempting the commands.
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2.1 Maple Input and Output
Read the text above and below each command for explanations of syntax and behavior.

❐ Be Patient!

Maple and other software sometimes confound students initially. So, you should expect

some frustration that will eventually subside. But, with enough practice and patience, you

can learn Maple as well as anything in this world.

2.1 Maple Input and Output

Maple provides a robust tool for mathematics, programming, and plotting. In general, you will fill

Maple worksheets with a collection of commands that Maple will act upon. This section

introduces basic methods of entering commands that will generate results in your worksheets.

2.1.1 Maple Input

Maple input consists of commands and mathematical expressions that you enter after the prompt,

which is the right angle bracket (>):

Maple displays all executable input in red by default. Consult ?contextmaplein in

?worksheet[reference] for descriptions of Context Bar icons available when entering

input.

> Enter Maple input here. But, never type the Maple prompt (>)!
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2.1 Maple Input and Output
2.1.2 Input Modes

Maple provides two input methods–Maple Notation and Standard Math–as demonstrated in

Table 2-1:

• Maple Notation: Input is one-dimensional. Maple reproduces keyboard character input for

mathematical expressions. Terminate this input by typing a semi-colon (;) or colon (:).

To process the input, press Enter or Return (↵).

• Standard Math: Input is two-dimensional. Maple converts keyboard character input into

typeset, textbook notation. To terminate and process input, press ↵ twice.

Note that you should never terminate help commands, like ?command, with a semicolon or

colon.

2.1.3 Choosing Input Modes

This text employs Maple Notation. You may switch input modes for a particular expression by

first highlighting that expression with your mouse. You can then either:

• Select either the notation toggle-icon , or

• Click the right mouse-button to select or deselect StandardMath.

You can also set a default mode with Options→InputDisplay:

• Choose either MapleNotation or StandardMathNotation.

• Then, press ↵  at the Maple prompt to activate the new mode.

Table 2-1 Maple Input Modes

Input Prompt Example

Maple Notation (a+b)/c

Standard Math

>

?> a b+
c

------------
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2.1 Maple Input and Output
Maple preserves your choice for future sessions if you have selected File→AutoSaveSetttings.

Consult ?insertmenu and ?worksheet[expressions] for more information.

2.1.4 Maple Output

After you press enter ↵ after Maple input, Maple executes the input and produces results called

Maple output. Maple output is shown in blue by default. Maple produces some output, like the

symbols , lim, and , in black. To see an example of output produced by Maple, compute the

sum  using the Maple Notation 1+1:

Step 1: Maple Input and Output

For descriptions of Context Bar icons available when manipulating, consult

?contextmapleout.

2.1.5 Error Messages

Inevitably, everyone confronts complaints from a computer in the form of error messages. For

instance, what happens if you forget a semicolon or colon? Maple will complain by reporting an

error message as output.

Step 2: Error Messages

> 1+1;↵ Red Input: Type 1+1;, and then press Enter. Evaluate the expression .

Blue Output: Maple produces the output .

> 1+1↵ Enter 1+1 without a terminating semicolon or colon.

>
Warning, premature end of input Maple reports a common error message.

Σ ∂

1 1+

1 1+

2 2
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2.1 Maple Input and Output
What should you do? Don’t worry, and don’t bang on the table in a fit of frustration! Trust me, I

already tried that – it took a week before my computer was restored. Instead, you should satisfy

Maple’s demands by fixing the error. You may do this without deleting the mistake:

• Place the cursor after the input 1+1 or at the next prompt (>).

• Type a semicolon and then press ↵ .

Maple will show the correct output 2. Now, Maple is “happy” once again. You should also try

Maple’s automatic correction mechanism by clicking on , which sometimes helps.

2.1.6 Multiple Inputs

Semicolons and colons terminate input command statements:

• A semicolon (;) signals the end of input. Maple evaluates the input and shows the output.

• A colon (:) tells Maple not only to perform the computations, but to suppress the results.

To place separate commands on the same input line, you may use semicolons and colons. For

example, try evaluating and on the same input line, but only show the results of

:

Step 3: Multiple Inputs

Yes, Maple really did compute , even though you do not see output. When you learn about

assignments, reasons for suppressing output become more apparent. (Yes, a little faith is required

when learning software.) Consult ?separator for more information.

> 1+1: 1+2;↵ Compute  but do not show output. Next, compute and show .

The colon suppresses the output of .

Practice!

1. Find Maple’s on-line glossary inside the Help Browser.

1 1+ 1 2+

1 2+

1 1+ 1 2+

3 1 1+

1 1+
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2.2 Documentation
2.2 Documentation

Why should you document your work? Today your worksheet might seem entirely clear, but what

about a year from now? And what about colleagues/graders/bosses that need to review your work?

Not only should your work be accurate, but clear as well – this section helps you with basic

elements of adding commentary to your worksheets. Also, Maple provides many word-processing

functions. For more information, consult ?worksheet[documenting], ?comments, or try

the menu options in Format.

2. Enter in both Maple Notation and Standard Math. (Hint Try the forward-slash key to

create the fraction.)

3. Ensure Maple Notation is the default input option.

4. Evaluate  with Maple.

5. Evaluate and on the same input line. Repeat this problem, but suppress the

output of .

1
2
---

1 2 3+ +

1 1+ 1 2×

1 1+
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2.2 Documentation
2.2.1 Text

You may document your work with text, which is composed of inert, non-executable input.‡

Maple displays text in black by default, though you may change the appearance as discussed in

?styles. To enter text, try the following three methods:

• Move the cursor one space to the left of the prompt, as shown in Figure 2-1. The

worksheet is now primed for text entry, so start typing.

• Select Insert→TextInput and type your text.

• Click the text icon  and type your text.

When finished, click on to get a Maple prompt. If you use the first method, you may also

press ↵ . See ?instext for more methods of text entry. Also, note that while in text mode, the

Context Bar changes with new fields and icons, as shown in Figure 2-1. Refer to

?contexttext for more information.

‡. Beware that text differs from Maple text, a format in which you may save entire worksheets.

Figure 2-1 Entering Text
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2.2 Documentation
Now you will enter text, using the methods described above. Each time you press ↵ , a prompt

will appear:

Step 4: Entering Text

To underline the “too,”

• Highlight the word with your mouse

• Click the underline icon  in the Context Bar while still in text mode

2.2.2 Comments

You may also document your work by mixing commentary and Maple input. To create a comment

on an input line, use the number sign symbol (#). Maple ignores all input following the #:

Step 5: Maple Comments

Consult ?comment for more information.

I am text!↵ Move the cursor left one space. Enter this line.

I am text, too!↵ Move the cursor left one space. Enter this line.

> The prompt reappears each time you press ↵ .

> 1*2; # multiply 1 and 2↵ Evaluate  and include a comment.

Maple produced output  but ignored the comment.

1 2×

2 2
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2.3 Execution Groups
2.2.3 Inert Math

You may also convert any executable, Maple input into inert input, a non-executable form of

Maple input shown in black. To do so, highlight the Maple input shown in red, and either:

• Click on the leaf icon , or

• Click the right mouse-button and deselect Maple Input

• To return input to an active, executable state select , or right-click your mouse and

select Maple Input.

2.3 Execution Groups

Have you noticed how Maple collects input and output together with range brackets on the left

side of a worksheet? Maple is trying to help you document your work. This section introduces

further techniques for helping you produce clear reports by collecting input, text, and output

together.

Practice!

6. Enter 1+1 along with the comment # I am a comment on the input line.

7. How do you convert inert input into executable Standard Math?

8. Can you convert text to Maple input? If so, how?
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2.3 Execution Groups
2.3.1 Paragraphs

Maple considers each line of text, input, and output as separate paragraphs:

• Add lines by selecting Insert→Paragraph followed by either Before or After.

• Delete lines with Edit→DeleteParagraph or the Del and Backspace keys.

Lines that contain graphical items, like spreadsheets and plots, are also paragraphs. To display

where Maple terminates paragraphs, select the icon or View→ ShowInvisibleCharacters. Maple

will identify individual paragraphs using the symbol ¶ and show other normally invisible

characters.

2.3.2 Creating Execution Groups

Execution groups collect paragraphs together. Execution groups can consist of one or more

paragraphs. Typically, input lines are followed by output lines inside one execution group. Range

brackets connect input and output paragraphs, as shown in Figure 2.4. Common tasks you may

perform with execution groups include

• Selecting View→ShowGroupRanges to show or remove brackets.

• Pressing ↵  or the icon  to create a new execution group.

• Selecting Insert→ExecutionGroup followed by BeforeCursor or AfterCursor to insert a new

group before or after the cursor.

Figure 2-2 Execution Group

> 1+1;

2

Maple Prompt

Maple Input

Maple Output

Range
Bracket
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2.3 Execution Groups
2.3.3 Joining Execution Groups

I strongly suggest you practice “playing” with software as a learning approach. So, this section

demonstrates steps that help you create execution groups that help you organize your work. You

will create two individual execution groups and then connect them to create the worksheet shown

in Figure 2-3.

Step 6: Create First Group

At the next prompt that appears, enter 1+2:

Step 7: Create Second Group

To join the groups in Steps 6 and 7,

• Place the cursor in the first execution group (Step 6), which has the input 1+1.

• Select Edit→SplitorJoin→JoinExecutionGroups.

Now, you will see the execution group:

Figure 2-3 Example Execution Group

I am text.↵ First, add a line of text.

> 1+1;↵ Next, enter input.

Maple generates and includes output in the group.

> 1+2;↵ Enter input.

Maple generates and includes output in the group.

2

3
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2.4 Maple Features
Step 8: Joined First and Second Groups

Now, click anywhere inside the group and press ↵ to reorganize the input and output lines. Maple

places all input paragraphs together and evaluates each input in sequence, from top to bottom:

Step 9: Reorganize Input and Output Lines

Refer to ?joingroup and ?executiongroups for more fun things you can do with

execution groups.

2.4 Maple Features

If you have not taken Maple’s online tour yet, perhaps you have only witnessed Maple’s

arithmetic skills. But, Maple is much more than a grandiose calculator! Maple offers you

I am text. This execution group is joined from the previous two groups.

> 1+1; This input is from Step 6.

This output is from Step 6.

> 1+2; This input is from Step 7.

This output is from Step 7.

I am text.
> 1+1;

> 1+2;

Practice!

9. Select View→ShowInvisibleCharacters or the icon. What do you see? Now turn off the

invisible-character display.

10. Create an execution group with three paragraphs of text and no Maple input.

11. Evaluate , , and  on separate paragraphs in the same execution group.

2

3

2

3

1 1+ 1 1– 1 2×
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2.4 Maple Features
powerful tools for solving complicated problems. Before solving those problems, however, you

need to continue developing your skills as a Maple user. So, try the features in this section before

continuing further. You should also consult ?worksheet or BasicFeatures… for online overviews.

2.4.1 Case Sensitivity

Maple distinguishes between upper and lower case letters: Maple is case sensitive! For instance,

never enter a when you mean A!

2.4.2 Expressions

A mathematical expression, like , combines numbers and symbols with operators. You

have already used basic arithmetic operators +, -, *, and /. Maple denotes symbols, like the

variables and , as names. Chapter 3 reviews names and operators. Refer to ?manipulation

for tips on selecting and editing expressions.

2.4.3 Functions

Maple functions help build expressions and have the structure func(arg1,arg2,…):

• func is the function name

• arg1, arg2, … are arguments that the function acts upon.

Suppose you want to take the square root of a number using Maple. Surely, someone working for

Maple has already programmed this for you. So, how do you find the function? Try the following

problems to find out.

Practice!

12. Perform a search for the text square root.

2x y+

x y
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2.4 Maple Features
Once you know the name of the function func, find help by entering ?func at the Maple

prompt, as discussed in Section 1.5.6. For example, enter ?sqrt for help on sqrt:

Step 10: Find Help on Function

To find the square root of an expression expr, enter sqrt(expr):

Step 11: Using a Function

Later chapters introduce many helpful functions for a variety of tasks. Appendix K summarizes

all the functions used in this text. For further information on how Maple stores and access

functions, refer to Appendix D.

2.4.1 Assignments

An assignment stores an expression “inside” a Maple variable name. Maple assignments have the

syntax name := expr, where name stores expr inside Maple’s memory.For instance, if I told

you to store the value of 72 in a variable called , you would enter x:=72 at a worksheet prompt.

Then, every time Maple sees , Maple really uses 72. So, a name resembles a variable which acts

as a placeholder for another expression. When entering assignments,

• Always put a colon (:) before the equals sign (=) with no space between them!

• Never use a lone equals sign (=)!

Try the following assignment, where you store the expression  using variable :

13. Scroll down the suggested help topics. How do you open one? Select sqrt.

> ?sqrt↵ Find help on sqrt. Maple opens a window that discusses sqrt.

> sqrt(4);↵ Find the square root of .

Maple succeeded! For more fun, enter sqrt(x^2).

4

2

x

x

1 1+ Var
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2.4 Maple Features
Step 12: Introducing Assignments

Maple first performs computations required by the expression before performing the

assignment. (Later on you will discover why.) Maple now considers all future occurrences of

as the value 2. Thus, you can check the value of  by entering the name as input:

Step 13: Checking Assigned Values

A new worksheet opened during a session might actually “know” previously assigned variables,

as discussed in Chapter 3. So, to erase assignments from Maple’s memory, enter restart at the

prompt in the worksheet in which you are working.

2.4.1 Graphics

A picture says a thousand words…when speaking of equations, think of graphs, or as Maple calls

them, plots. When analyzing a model, a plot demonstrates qualitative behaviors not readily

apparent in the mathematics.

> Var := 1+1;↵ Compute  and store the value “inside” .

Maple reports your assignment.

> Var;↵ What value does  contain?

Maple reports the value of .

Practice!

14. Store the value 2 in . Store the value 1 in .

15. Check the values of  and . Why should  and  report different output?

16. Now, enter restart. Check the values of  and . What happened?

1 1+ Var

Var 2:=

1 1+

Var

Var

Var

2 Var

x X

x X x X

x X
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2.4 Maple Features
Maple provides an excellent tool for generating plots of expressions. For instance, try plotting

the equation, on . To plot as a function of , use a function of the

form plot(expr,ranges,options) with the following arguments:

• expr: enter the expression as 2*x+3. If you previously entered y:=2*x+3, you

may enter y, instead. But, never enter y=2*x+3 because plot cannot handle expressions

that include the equal sign.

• range: enter the interval of the independent variable  as the range x=0..5.

• option: display a title using the option title="plot title".

Step 14: Basic Plotting

Maple’s default setup has plots appear in an execution group. To place plots in a separate window,

select the menu Option→PlotDisplay→Window. Review Chapter 8 and Graphics… to explore more of

Maple’s plotting features.

> plot(2*x+3,x=0..5,title="Test Plot");↵ Plot  along .

Practice!

17. Assign to  the expression .

18. Plot  for . Title your plot “Hello, I am a plot”.

y f x( ) 2x 3+= = 0 x 5≤ ≤ y x

2x 3+

0 x 5≤ ≤

f x( ) 2x 3+= 0 x 5≤ ≤

4

6

8

10

12

0 1 2 3 4 5x

Test Plot

y 2 x

y 0 x 100≤ ≤
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2.5 Learning Tools
2.4.1 Spreadsheets

When working with multiple expressions, Maple provides tools for creating and accessing

spreadsheets in your execution groups. Review Appendix F for a thorough discussion.

2.4.2 Worksheet Management

Worksheet management consists of operations performed on entire worksheets including the

workspace. You should consult Appendix C and ?workspace[managing] for detailed

explanations of operations, like opening and closing. Beware that saving work in Maple

Worksheet “mws” format creates a file only Maple understands. Never print these files!

2.4.3 Miscellaneous

Various appendices in this book demonstrate other features, such as programming and MATLAB,

that you might find useful after gaining more experience with Maple.

2.5 Learning Tools

Sometimes learning new software can be overwhelming – there’s so much to learn. With Maple,

memorizing the thousands of commands might seem insurmountable. Thankfully, online

Practice!

19. Save an open worksheet as test1.mws.

20. Open a new worksheet. Save it as test2.mws.

21. Print test1.mws to a PostScript file test1.ps. Can you load test1.ps into

Maple? Can you directly print test1.mws?
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2.5 Learning Tools
documentation explains most everything you will need to do. Maple also provides other tools that

help you learn. In time, you might drift away from some of these features as you become more

experienced. But for now, review the tips in this section and use them in your early Maple

explorations.

2.5.1 Palettes

Maple’s palettes are “clickable” windows that provide templates for choosing common

commands that you might wish to enter. If Maple does not show any palette windows, select

View→Palettes→ShowAllPalettes. Inside the Maple workspace, three palettes will appear: the

expression, symbol, and matrix palettes. Figures 2-4 and 2-5 show the symbol and expression

palettes. Chapter 10 will demonstrate the matrix palette. You will find online documentation in

?worksheet,expressions,palettes.

Figure 2-4 Symbol Palette

Figure 2-5 Expression Palette
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2.5 Learning Tools
2.5.2 Symbol Palette

Using a palette resembles ordering a meal at a restaurant. First, you identify what you want to

“eat,” or enter. Then you “order,” or select it. Suppose you’re “hungry” to enter the symbol but

can’t figure out what it’s really called other than “squiggle”. Well, to “order squiggle” from your

palette,

• Move your cursor to the position you wish to insert a symbol in your worksheet.

• Click on the symbol in the palette.

Maple’s name for the symbol will appear in your worksheet. For instance, try inserting “squiggle”

using the palette:

Step 15: Entering a Symbol

Want to discover more names for other symbols? Use the Symbol Palette or check out

Appendix A. See also ?symbols.

2.5.3 Expression Palette

What if you want to enter an expression but you do not know Maple’s command names? As you

used the symbol palette, you will select items from the expression palette using your mouse. But,

unlike the symbol palette, the expression palette entries are patterns that you will fill in at the

prompt. For example, clicking on the a+b pattern will not actually use an a and b. Rather, Maple

inserts placeholders which have the form %? for Maple Notation or ? for Standard Math. For

expressions with multiple placeholders, press the Tab key to move to a new placeholder.

Place the cursor in a new input paragraph, find the Symbol Palette, and click on the  symbol.

> xi;↵ The Maple input xi; will appear.

After you press ↵  Maple shows the symbol in the correct font.

ξ

ξ

ξ
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2.5 Learning Tools
For instance, suppose you need to evaluate the expression . Using Maple Notation,

perform the following instructions:

Step 16: Entering a Symbol

To fill in the values, use the Tab key to jump between placeholders and then type your input:

Step 17: Filling in placeholders

When using Standard Math, the Context Bar will show a box called the edit field, which contains

the expression in Maple Notation. Using the edit field along with the palette is another great way

to learn Maple commands.

2.5.4 Context Sensitive Menu

What should you do when you are looking for a particular function but you do not know the exact

name? You could perform a topic or text search, as described in Appendix B. For an even quicker

search,

• Highlight the expression you wish to manipulate.

• Right click the expression.

Maple will display a context-sensitive menu which contains selections for “common” commands

used with expressions that resemble the one you highlighted. By selecting a menu option, Maple

will figure out the input for you and type it in a new execution group. For example, try

manipulating the expression :

Select , press Tab, select , press Tab, select  from the Expression Palette.

> ((%?)*(%?^sqrt(%?))); Maple automatically types this expression as you select palette items.

Move cursor to beginning of input, press Tab, enter 4, press Tab, enter x, press Tab, and enter 2.

> ((4)*(x^sqrt(2)));↵ You may also manually delete any placeholder (%?).

Maple generates the output you expected.

4x
2

a b× a
b

a

4x
2( )

x
2

4x 4+ +
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2.5 Learning Tools
Step 18: Context-sensitive menu

So, what was the function Maple used? Try entering factor(x*x + 4*x + 4) to produce

the same result. Although Maple won’t tell you the function name, the function name tends to

match its equivalent in the context-sensitive menu. For more information, consult Basic

Features...Mathematics...context-sensitive menus or ?manipulatecsm. What if you don’t like the

choices provided to you? Adventurous students should investigate ?context and

?examples[context] to create their own menus.

2.5.5 Smartplots

Sometimes some expressions require a lot of tinkering with options to obtain a useful plot. To

save time, you may want to let Maple hazard a few guesses on its own using a smartplot. A

smartplot is a plot automatically generated by Maple where you let Maple select the options. You

may then use context-sensitive menus to manipulate the plot. To generate a smartplot, follow the

same steps for getting a context-sensitive menu and select Plots. You should choose a type of plot,

like two- or three-dimensional, from a sub-menu. For instance, you can generate a three-

dimensional (3-D) plot:

Step 19: Smartplot

> x*x + 4*x + 4; Trying the expression palette, instead, gives

((%?^%?)+(((%?)*%?))+%?);.

Everything is OK here.

Select the output  with the left mouse-button, then right-click the mouse, and select Factor.

> (x+2)^2; Maple automatically factors the expression for you.

> x*cos(y)-sin(y); Enter the expression. Using two different variables will make the plot 3-D.

You may also use the expression palette.

x
2

4x 4+ +

x2 4x 4+ +

x y( )cos y( )sin–
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2.5 Learning Tools
To alter features of the plot, as shown in Figure 2-6,

• Click on the plot – the outer box indicates that the plot may be altered

• Right-click to see a variety of menu options

Although “normal” plots have context-sensitive menus, the smartplots have additional options,

like adjusting the plot ranges with Axes→Ranges. For more information, consult ?contextmenu

and ?smartplot.

Select the output, right-click, and select Plots→3-D Plot→x,y.

> smartplot3d[x,y](x*cos(y)-sin(y)); Maple automatically enters this expression and

generates the plot as output in this execution group.

Maple indicates that the plot is a smartplot using the word Live.

Figure 2-6 Altered Smartplot

Live
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2.6 Application: Zebra Mussels
2.5.6 Maple Application Center

Formerly, Maple provided a share-library which contained a collection of worksheets. Now,

Maple has combined the entire share-library with an online collection of worksheets covering a

vast array of applications. Consult ?share for more information. Remember, also, to check out

example worksheets listed in ?examples[index].

2.6 Application: Zebra Mussels

This section demonstrates a brief example from environmental engineering and science that

illustrates key Maple commands.

2.6.1 Background

Sometimes, big engineering problems come in small packages…perhaps millions of them. Zebra

mussels have infested some North-American waterways. Check out the image in Figure 2-7!

These remarkably sturdy aquatic creatures clog pipes and foul water. Much research is devoted to

dealing with these pests.

Practice!

22. What Maple input will generate the output ?

23. What Maple input will generate the output ?

24. Generate the plot shown in Figure 2-6. Hint: Use the context-sensitive menus.

δισ

x

y 2+
----------------
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2.6 Application: Zebra Mussels
Assume that the exponential-growth equation

(2-1)

governs the zebra-mussel population in a given body of water. Parameter represents the initial

size of the colony, which has a growth rate  over time period .

2.6.2 Problem

Given a growth rate , what relative population growth does the model in Eq.

2-1 predict in a span of ten years?

2.6.3 Methodology

Inside Maple, retype pertinent parameters and data:

Figure 2-7 Zebra Mussels (Courtesy of U.S. Geological Survey, Great Lakes Science Center)

P P0 rt( )exp=

P0

r t

r 0.9= years
1–( ) P
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2.6 Application: Zebra Mussels
Step 20: Zebra Mussel – Restate

Next, state your known data, and assign Maple variables to these values:

Step 21: Zebra Mussel – Separate

Now, assign the model in Eq. 2-1. Using an assignment statement, place the unknown variable

on the left and the function on the right. Express the function  as :

Step 22: Zebra Mussel – Model

Since the problem has not provided an initial zebra mussel count, divide the equation by , and

plot  for the given time interval  years:

Step 23: Zebra Mussel – Solve

Wow…that looks like a lot of pesky zebra mussels! Finally, find the relative increase at ten years:

P = population and P0 = initial population (units=critters/m^2)↵ Enter text.

r = growth rate (1/year) and t = time (year)↵ Enter text.

> r:=0.9;↵ Assign to the name  the value .

Maple reports your assignment.

> P:=(P0)*(exp(r*t));↵ Assign to the name  the expression .

The function is written as , as discussed

 in Chapter 6. For now, just duplicate the input written here.

> plot(P/P0,t=0..10,title="Exponential Growth")↵

r 0.9

r .9:=

P

e
rt

rt( )exp

P P0 rt( )exp

P P0e.9t
:= x( )exp ex

P0

P P0⁄ 0 t 10≤ ≤

0

2000

4000

6000

8000

2 4 6 8 10t

Exponential Growth
Introduction to Maple 26



2.6 Application: Zebra Mussels
Step 24: Zebra Mussel – Report

2.6.4 Solution

After 10 years, the zebra-mussel population will have grown to about 8000 times the original

population, according to the chosen model. The exponential function models rapid and

compounding changes, as that of zebra-mussel reproduction. However, this model provides only a

crude approximation. Numerous factors that were not represented in the model contribute to the

growth and death of zebra mussels.

Summary

• The Maple worksheet contains computations and documentation.

• A user may find online help with the help operator ?.

• The user enters Maple input to evaluate output.

• Execution groups collect input and output.

• Many Maple commands consist of expressions which contain variables, functions, and

values.

• Assignments store values inside variables.

• Maple provides useful tools, like palettes and context-sensitive menus, that help users

learn the software.

• Maple creates graphs of expressions with plots.

> t:=10: P/P0;↵ Assign to  the value , but suppress the output.

In the same input line, evaluate the relative increase.

Maple’s evaluation of the expression .

t 10

8103.083928 P
P0
------
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2.6 Application: Zebra Mussels
Key Terms

active input

assignment

case sensitive

context-sensitive menu

expression

execution group

inert input

Maple input

Maple Notation

Maple output

palette

paragraph

plot

smartplot

Standard Math

text

Problems

Write your answers to the problems inside a Maple worksheet. Be neat and beware of case-

sensitive variable names! Use the following the format, unless instructed otherwise:

Problem 0.1

Solve for .

> 1+1;

1 1+
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2.6 Application: Zebra Mussels
1. Enter the following information on the top of your worksheet:

2. What is Maple?

3. Specify three uses of Maple.

4. What is an execution group?

5. Indicate the menu selections to insert both a section and a subsection.

6. How do active and inert input differ?

7. How do Maple input and output differ?

8. How do Standard Math and Maple Notation differ?

9. Find help on Maple “help” and using the ? command.

10. Find help on Maple names.

11. Suppose that you save your worksheet to hw1.mws using the menu-selection sequence

File→SaveAs…. Assume that you then exit Maple. How can you print the contents of

hw1.mws?

12. Assign to the name  the value 10.

13. Assign to the name  the expression .

14. Evaluate , , , and  using Maple.

15. Start a fresh Maple session. Enter the following Maple input:

HOMEWORK 1
Name:
Section:
Date:

> A:=2:

2

B1

B2 1 1
2
---+

1 2+ 1 2– 1 2× 1 2÷
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2.6 Application: Zebra Mussels
Generate output from the following input:

Does Maple report the same values for  and ? Why or why not?

16. Assign to the expression , but prevent Maple from showing the output. Next,

display the value of  in a new execution group.

17. Find help on the sine function. Next, demonstrate that Maple evaluates to the

value of 1. Hint: Use the symbol palette to enter .

18. Plot  for . Label your plot “Parabola.”

19. Plot  for  and  over the domain .

20. Produce execution groups in Maple that look like what you see written below:

> A; a;

Problem 20a.
> 1+1:

> `Hello`;

> EQN := y=m*x+b:

> A:=10:

Problem 20b.
Hello, I am just text.
Now, try boldface and italic styles.
> # I am just a happy comment :-)

Problem 20c.
Use the backslash (\) as a continuation character for Maple input:
> 1 + 2 +\

> 3 + 4;

A a

B3
100
10
---------

B3

π
2
--- 

 sin

π

y x
2

= 0 x 2≤ ≤

y mx b+= m 1= b 1–= 2– x 2≤ ≤

Hello

10
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2.6 Application: Zebra Mussels
Problem 20d.

Here is an embedded inert equation . Hint: Investigate the Insert menu selections.

Here is the same equation, , but now it’s active input. Hint: Investigate the icons on

the context bar.

Problem 20e. Hint: See ?structuring2.

a b+
c

------------

a b+
c

------------

a b+
c

------------
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