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Objectives

After reading this chapter, you should be able to:

• Relate engineering and science to problem solving

• Compare mathematics and computers to tools

• Understand how Maple operates

• Explain the problem-solving process

• Describe the notations employed in this text

• Identify elements of the Maple workspace

• Access on-line help

• Create, open, save, and print worksheets
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1.1 A Beginning
1.1 A Beginning

Have you asked, yet, why should you learn Maple? Perhaps a teacher or colleague might tell you,

“Because Maple is a great program that solves hard problems,” or, perhaps, “Because you have

to.” Yes, your teachers probably expect a measure of faith that you believe in Maple. Throughout

this text, I hope to demonstrate Maple’s power and elegance. For now, read through this chapter to

get a “taste” for Maple.

1.1.1 Problems

Maple is about problem solving. What distinguishes engineering and science problems from

other problems? Certainly not all tasks require an engineer or scientist! Loosely defined, scientists

develop theoretical concepts of the physical world, and engineers then apply these theories to

create physical systems, devices like light-bulbs and toenail clippers. Yes, physics helps to keep

our nails trimmed!

1.1.2 Tools

How do people construct devices? Usually, with tools. Tools assist with thinking, analysis, testing,

and making things that solve problems. Tools include physical devices and abstract methods.

Physical tools, like machinery, extend human physical capabilities. Abstract tools, like

algorithms, enhance problem solving.

1.1.3 Modeling

Models are tools that analyze and predict physical behaviors. Science and engineering models

often combine features of physical and abstract tools. Using algorithms and equations, for
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1.1 A Beginning
example, manufactures often build prototypes before mass-marketing goods for testing after

designing. Well-devised models reasonably and efficiently predict accurate behaviors. The

abstract model provides a design, whereas the prototype provides a reality-check to see if the

device really works.

1.1.4 Experimentation

Experimentation yields good models. For instance, consider a building and the idealized model

of it, as shown in Figure 1-1. Over many years, laboratory testing and theoretical development

have provided engineers with idealized, mathematical models that assist in structural design.

Continued testing between idealized and actual behaviors improves both understanding and

development of better models.‡

Figure 1-1 Basic Modeling

‡. Can buildings have prototypes, like other mass-marketed goods? Imagine having to destroy buildings in
succession until building a one that won’t topple! Here, robust abstract models are crucial.
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1.1 A Beginning
1.1.5 Mathematics

Mathematics provides abstract models. Scientists and engineers represent physical processes with

equations. Mathematical models usually involve a combination of symbolic and numerical

features:

• A symbolic model is qualitative, because it represents a general equation. For instance, the

equation represents a symbolic mathematical model, where the letters , ,

, and  represent different numerical values.

• A numerical model is quantitative because it substitutes specific numerical values for the

terms in a symbolic model. For instance, using values , and ,

produces a quantitative result of .

1.1.6 Computers

Tools, such as computers, assist in complex mathematical analysis and other burdensome tasks.

Hardware and software make up the “body” and “mind” of a computer, respectively. Hardware

consists of the physical devices. Software provides the “intelligence” for computations and

communication. So, what makes software a tool? Software helps people solve problems as with

any other tool.‡

‡. Application software implements mathematical models for analysis and design. Understand, however, a
program’s assumptions and limitations, as you would with any model! Always check your output with
simpler, “textbook” models.
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1.2 Maple
1.2 Maple

Maple provides a powerful software tool used primarily for symbolic analysis, but has presently

strengthened its numerical abilities. This section provides a brief overview of Maple’s capabilities

and structure.

1.2.1 Computer Algebra System

Maple implements a computer algebra system (CAS) for symbolic mathematics. A CAS provides

commands for manipulating and deriving symbolic equations from other equations. A software

“engine” inside a CAS uses analytical methods to find exact answers, often in symbolic form.

Maple employs numerical methods as well, and now implements many numerical routines with

NAG (Numerical Algorithms Group).

1.2.2 History of Maple

Computer-based, symbolic analysis was introduced in the late 1960’s. In case you’re curious

where the name Waterloo Maple came from, Symbolic Computation Group at the University of

Waterloo in Canada started Maple as a project in 1980. Eventually, Waterloo Maple, Inc.

commercially released Maple. Maple has remained popular in both academic and commercial

environments.
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1.2 Maple
1.2.3 Why Maple?

Maple is very useful for a number of reasons. Maple does the following:

• performs symbolic and numerical analysis for a wide variety of tasks.

• contains a rich library of over 2500 functions.

• helps you construct customized programs by using Maple commands.

• provides access to other popular software packages.

1.2.4 How Does Maple Work?

The kernel, library, and an interface make up the structure of Maple, as shown in Figure 1-2:

• Kernel: About 10% of Maple functions make up the Maple kernel, the core command

group. These commands interpret and process input, evaluate numerical quantities, and

manage memory. Maple provides both shared and parallel kernels, as discussed in

Chapter 3.

• Library: About 90% of Maple’s commands called functions are written in Maple code and

kernel operations. For example, entering sin(0) causes Maple to evaluate the value of

the function . Functions automatically load when starting Maple. Some functions

Figure 1-2 Maple Structure
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1.3 Using Maple
are stored in library packages which require special loading procedures, as discussed in

Appendix D.

• Interface: The user communicates with Maple through the interface. Maple interprets

commands and evaluates the desired procedures. Although Maple provides a text-based

interface, this text focuses on the graphical user interface (GUI) version of Maple which

uses menus and windows. These interfaces are discussed in the next chapter.

• User: That’s you!

1.3 Using Maple

This text covers the version of Maple called Maple 6. A few important distinctions with the

previous version, Vr5, are noted throughout the text. Beware that not all computer platforms

support these same features.

1.3.1 Problem-Solving Methodology

Each chapter in this book applies Maple for solving a variety of problems. As you work through

these problems, follow a general problem-solving methodology, as illustrated in Figure 1-3. In

general, break problems down into smaller, more manageable subproblems. Also, when steps fail,

go back to previous steps and iterate for better solutions. You might wish to think of this process

as a more refined “trial-and-error” system.
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1.4 Maple Environment
1.3.2 Notation

Before attempting anything, thoroughly review the notation in Table 1-1. Computer manuals and

textbooks are typically awash with such notation. I suggest you tab that page because you’ll need

it while getting used to this text.

1.4 Maple Environment

This section provides a brief overview of Maple’s GUI environment. You should try all Practice!

problems after reading the following material.

Restate the problem:
• Understand all terms and concepts.
• Collect references that cover the problem scope.

Separate “knowns” from “unknowns”:
• Tabulate given information (“knowns”) to clarify required output (“unknowns”).
• Seek additional information not explicitly expressed.

Build a model:
• Decide which physical principles apply to the system.
• Break down large problems into smaller “sub-problems” to ease analysis.

Solve the equations:
• Choose the techniques to solve the equations.
• Try Maple!

Report the output:
• Check your output for quantitative and qualitative accuracy.
• Compare your output with results from other techniques.

Figure 1-3 Problem-Solving Methodology
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1.4 Maple Environment

Table 1-1

No
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1.4.1 Starting Maple

Maple provides two basic environments:

• Command Line, as shown in Figure 1-4. Consider using this text-based version when you

have become more experienced with Maple or need to run only a few commands.

• GUI, as shown with annotations in Figure 1-5. This text will focus on this version.

Notation

tation Description

Key Terms These terms involve important concepts and are shown in boldface italics.
There is a list of key terms at the end of each chapter.

Input input and commands are shown in boldface, fixed-width font. For example, you would
the mathematical expression  as sin(x).

guments Many Maple commands take arguments, which are values that can vary. Arguments are s
in boldface italicized fixed-width font. Never type the literal word “argument”! Always
the value of “argument” instead.

Output
and

Equations

GUI Maple reports most output in italics. Why? Many textbooks show mathematical
expressions and equations in italics. For example, entering sin(x) in Maple would prod
the output .

omputer When you make a mistake, Maple sometimes produces output in fixed-width font called a
error message to report your blunder.

Text You may also add plain text in Maple. Although Maple allows different fonts, this book s
plain text in this font.

commentary My comments are shown in this small, italic font. Never enter these comments into Maple
commands!

↵ Press the Enter or Return key on your keyboard.

1→Menu2 Select Menu items by pointing and clicking the left mouse button. For instance, the seque
Edit→Execute→Worksheet instructs you to select Edit. You may now select from the submen
Point your mouse on Execute. Finally, click on Worksheet. You can also press the Alt key a
with the underlined letter to select a particular item on the first in a sequence of menu selec
Do not press Alt again to activate a submenu.

Subtopic Point and click your mouse inside the Help Browser for help on specific topics. Appendix
explains how to access the Help Browser and find more help in Maple.

x( )sin

x( )sin
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1.4 Maple Environment
To start the GUI version of Maple:

• Windows or MacIntosh: Click the Maple icon

• Unix or Linux: Enter xmaple or maple -x at the shell prompt

Refer to Waterloo Maple’s website in Appendix H for a complete list of supported operating

systems.

dis@mobius% maple

|\^/| Maple 6 (SUN SPARC SOLARIS)
._|\| |/|_. Copyright (c) 2000 by Waterloo Maple Inc.
\ MAPLE / All rights reserved. Maple 6 is a registered trademark of
<____ ____> Waterloo Maple Inc.

| Type ? for help.

> Enter commands here. Exit with quit, done, or stop.

Figure 1-4 Command-Line Maple Interface

Figure 1-5 Maple Window
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1.4 Maple Environment
1.4.2 GUI Interface

You’re about to take your first steps through Maple. Start up the GUI version of Maple and

compare the window that pops up with Figure 1-5. Look at the following components of the

window, summarized in Table 1-2.

1.4.3 Item Selection

Maple uses two different methods to access menus with the mouse.

• A left click means that you press and release the left mouse-button (Windows and Unix) or

the sole mouse button (MacIntosh) to select menus, worksheets, and items inside

worksheets.

• A right click means that you press and release the right mouse-button (Windows and Unix)

or press the Option key (MacIntosh) to perform other important functions discussed

throughout this text.

• A double or triple click means that you rapidly left click two or times.

Table 1-2 Elements of Maple GUI

Feature Description Reference

Menu Bar Select commands with your mouse or the Alt key. ?menus

Tool Bar
Click on these icons for shortcuts. These icons change
based on the tasks you perform, like accessing help or
plots.

?toolbar

Context Bar
Change input and output formats, halt execution, and
edit commands.

?contextbar

Title Bar
Click on the Title Bar icons for resizing, iconifying, and
closing a worksheet.

?glossary

Worksheet Create documents that communicate with Maple. ?worksheet

Workspace Open multiple worksheets and other Maple windows. ?windowmenu
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1.5 Help!
In general, to select a menu, move the mouse until the cursor points over the item and left click,

unless a right click is specified.

1.5 Help!

This section will help you become familiar with Maple’s on-line help. A “seasoned” Maple user

tends to rely on Maple’s on-line help to answer questions, but many Help features assist the new

and inexperienced users.

1.5.1 Help Menu

To investigate Maple’s Help system, left click on the Help menu using your mouse. When first

using Maple, select Help→BalloonHelp. Little balloons with helpful information will appear when

you touch any icon and menu option. Eventually you will find these balloons irritating, but until

you know every single one, I recommend leaving the balloon help on.

1.5.2 Tutorials

New Maple users should select Help→NewUser’sTour and Help→Introduction for an overview of

Maple features. Chapter 2 of this book provides an overview also.

Practice!

1. Which appendix in this book has solutions to Practice problems?

2. Locate and activate Maple on your system.

3. Which version of Maple do you use?
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1.5 Help!
1.5.3 Help Browser

Maple has an excellent tool for finding help on commands called the Help Browser, as shown in

Figure 1-6. You can open the Help Browser with the following actions:

• Select Help→UsingHelp and other menu selections, like Help→Introduction.

• Type ? or ?? at the Maple prompt (>) and press Enter or Return (↵ ).

• Find help on commands using ?command or a text or topic search under Help (See the

following sections.)

The Help Browser organizes many of Maple’s resources in categories called topics. Typically,

topics describe commands with help on syntax, usage, and examples. Left click once on topics

listed as Topic… in the left column to open subtopics that will appear to the right of the topics. You

may also left click on the Tool Bar icons that appear below the workspace menus to move forward

and backwards along topics. .

1.5.4 Sections and Subsections

Help topics typically organize information with sections, indicated by the icons and .

Sections collect text, execution groups, and other sections. Subsections are sections that are

contained inside other sections.

• Left click on the  icon to expand a section.

• Left click on the  icon to collapse a section.
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1.5 Help!
1.5.5 Hyperlinks

Many topics and other keywords are provided as hyperlinks. Hyperlinks are active text that

“jump” to other topics or display information. Maple typically displays hyperlinks as colored,

underlined text. Left click once to activate a hyperlink.

1.5.6 Command Line Help

Regardless of interface, you can enter ?topic at the Maple prompt (>) for help on topic:

• Type a question mark (?) followed by command.

• Press the Enter or Return key (↵ ).

Figure 1-6 Help Browser
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1.5 Help!
Figure 1-7 demonstrates how to get help on the sqrt command. At the prompt you would type

?sqrt and then press ↵ . Maple pops up the Help Browser with the appropriate Help page

loaded. If you are uncertain of the topic name, which is usually a command-name, just type one or

two letters. Maple will display all topic names that start with those letters. .

1.5.7 Topic Search

Select Help→TopicSearch… to search for topics, such as command names. You should type a few

letters of the topic name in the box next to Topic. As long as the Auto-Search feature is activated,

Maple will automatically search for matching topics as you type the letters. For instance, try

searching for dis, as shown in Figure 1-8. Maple will suggest topics that appear below such as

disassemble and discont. Double-click on the topic names to investigate Maple’s

suggestions. If you select discont, Maple will pop open the Help Browser with the discont

topic-page loaded.

Figure 1-7 Getting Help on a Topic
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1.5.8 Text Search

If you are uncertain of a topic or command name, try a text search with Help→FullTextSearch…. In

the box next to Word(s), type the words for which you are searching and press the Search button.

Maple will suggest topics that might match your inquiry. Double-click on a topic to open the Help

page associated with the topic.

1.5.9 Examples

Maple provides many example worksheets that cover a wide variety of topics and applications.

For on-line examples, enter ?examples[index] at the prompt. For a much larger directory,

refer to the Maple Application Center at Maple’s website site, listed along with other web

resources in Appendix H.

Figure 1-8 Topic Search

Practice!

4. What Help topic in Maple contains the word suck? (Yes, there really is one.)

5. Activate Help→BalloonHelp. Point your mouse on an icon and on a menu. What happens?
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1.6 The Maple Worksheet

The Maple worksheet provides your main interface for communicating and working with Maple.

In a way, a Maple worksheet resembles a document you would create with a word processor. At

the prompt, you may enter commands, find help, and write text to create documents that contain

commentary and the results of computations. This chapter explores many of these features as

described in ?worksheet, ?worksheet[interface], and ?worksheet

[management].

1.6.1 Creating a Worksheet

By default, Maple starts with an empty worksheet. To work on a different worksheet, create a new

worksheet by selecting the icon or menu File→New. During a session, Maple labels each

worksheet as “Untitled [number]” on the Title Bar in ascending order according to newness.

1.6.2 Workspace

Select Window options to organize and rearrange worksheets and all other Maple windows inside

your workspace. For instance, try opening a few worksheets inside a Maple workspace. You may

then select Window→Tile to display all windows next to one another in a tile-pattern.

6. Activate File→AutoSaveSettings. What happens when you select this menu option?
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1.6.3 Moving Around Your Worksheet

Generally, you may move around your worksheet by

• Pointing and clicking the mouse inside the worksheet

• Pressing the arrow keys to change the position of the cursor

Avoid moving the cursor with the Backspace, Del, and Enter (↵ ) keys. In the Help Browser,

consult BasicFeatures…Navigation… for further information on other ways to move around the

worksheet. Eventually, you should investigate keyboard shortcuts using ?hotmac, ?hotunix,

or ?hotwin.

1.6.4 Editing

To perform editing functions, like copying, cutting, and pasting, use the mouse to highlight

portions of your worksheet:

• Move the mouse to the portion of the text you wish to edit.

• Left click the mouse.

• Drag the mouse over the portion you are editing

You may select Edit or the Tool Bar icons for many editing operations. You can also delete items

by selecting them with your left mouse button and pressing the Del and Backspace keys. Consult

?editmenu , ?documenting, and ?toolbar for more information.
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1.6.5 Saving

Save your work! You never know when the system might crash. Select the icon or the menu

File→SaveAs… to name and save worksheets, as shown in Figure 1-9:

• Folders or DIrectory: Change folders and directories by double-clicking on the folder name.

• File name: Delete the asterisk (*) and type a name that ends with .mws, like hw1.mws.

• Save file as type or Filetype: Leave the type on Maple Worksheet. Worksheets saved in this

format preserve the entire contents in a format you open directly into Maple. See Section

1.6.7 for more information on Maple’s worksheet format.

Click on OK when your chosen file name satisfies you. The new name will appear on the left side

of the Title Bar on the worksheet. Once you have named your worksheet, frequently select

File→Save to save your work. For more information, consult ?worksheet,managing,

saving.

1.6.6 Exporting Worksheets

You can save your work to different formats by selecting File→ExportAs…. If you prefer, you can

Figure 1-9 Save Worksheet
Introduction to Maple 19



1.6 The Maple Worksheet
also select File→SaveAs… and then save the worksheet to another type of file. Note that exporting a

worksheet to another format only exports the current version of your work. You have to export

your worksheet again if you wish to incorporate changes inside the saved file. Some common

formats include:

• Maple Worksheet (MWS): Maple Worksheet format (See next section.)

• HTML: Convert your worksheet to HTML for the World Wide Web. See ?xprt2html for

more details.

• Maple Text: A text-based representation of the Maple worksheet. Save in this format the

worksheet needs to be imported back into Maple. The command-line version of Maple

typically saves in this format. In general, you should stick to using MWS, instead.

Consult ?worksheet,managing,export for more information about these and other

formats.

1.6.7 Worksheet Format (MWS)

When you save a worksheet in the type called “Maple Worksheet,” Maple stores that worksheet’s

contents into a text file that only Maple understands. These files, which typically have the

extension .mws, are written as ASCII, which is a universally understood form of text. However,

text written in MWS-format is unintelligible and will produce garbled printouts. You should only

print MWS files from within Maple, as discussed in Section 1.6.9.

1.6.8 Opening Worksheets

Load previously saved worksheets by selecting the icon or menu File→Open. The window that

pops up, shown in Figure 1-10, resembles the “Save As” window. Select a directory by clicking
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1.6 The Maple Worksheet
on Folders or Directory. “Open” automatically lists files with mws extensions. Click on an existing

file or type the name of a file under File name. Click on OK to load the worksheet. For information,

consult ?worksheet,managing,export.

1.6.9 Printing

Print your worksheet by selecting the icon or menu File→Print…. From the “Print” window

shown in Figure 1-11 you have two choices for printing:

• File: Click on Print to file (Unix users should select Output to File.) A checkmark (✔ ) will appear

in the box to the right. (For Unix users, an indented diamond .) Then, click on OK. Maple

then creates a PostScript file containing the contents of your worksheet. Maple will then

prompt you to enter a file name. Choose a name, like something.ps. See the next section

for further description of PostScript.

• Hardcopy: Ensure that the Print to file box has no checkmark (✔ ). Then, click on OK. (Unix

users should select Print Command and then enter lpr -Pprinter or lp -dprinter in

the box to the right.)

Figure 1-10 Open Worksheet
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1.6 The Maple Worksheet
Also, try File→PrintPreview… to view a file before printing it.

1.6.10 PostScript

PostScript (PS) is another kind of text-based formatting that creates files that print on virtually

every kind of printer. The first line in a PS file typically starts with %!PS-Adobe. Beware of the

difference between PostScript and Maple’s MWS files! Maple cannot open PostScript files, so

always retain both PostScript and MWS versions of your worksheets. Remember, also, you

should never directly print a file stored in MWS format unless you use Maple’s File→Print…

command sequence!

1.6.11 Quitting Maple

To end your Maple session, enter File→Exit. Maple will then prompt you to save unsaved

Figure 1-11 Print Worksheet
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1.6 The Maple Worksheet
worksheets. When using the command-line version of Maple, enter quit.

Summary

• A variety of tools help solve science and engineering problems.

• Tools include both physical devices and abstract methods.

• Computer programs implement models derived from scientific principles and

experimentation to ease analysis and improve accuracy.

• Computer algebra systems provide both symbolic and numerical analysis.

• Maple is a computer algebra system.

• Three basic components – the kernel, libraries, and interface – form Maple.

• You may search for help using Maple’s Help Browser, which accessed via the Help menu

or the prompt (?).

• You should save worksheets in Maple’s own MWS format, but you may not print those

files. To print a worksheet, you may use File→Print….

Practice!

7. Create a new worksheet.

8. Save the worksheet to a file called temp1.mws. What type should you pick for the file?

What does the Title Bar for the worksheet now display?

9. Print the worksheet to a file called temp1.ps.

10. Close the worksheet.

11. Re-open the worksheet. Can you load the file called temp1.ps? Why or why not?

12. Exit from Maple.
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Key Terms

analytical method

computer

computer algebra system (CAS)

engineering

experimentation

graphical user interface (GUI)

Maple

Maple interface

Maple library

Maple kernel

Maple Worksheet format (MWS)

mathematics

models

numerical model

PostScript (PS)

science

symbolic model

tools

worksheet
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